fbpx

What’s changing?

One of our priorities is to ensure your data is always protected in accordance with the latest industry standards. As part of this, we’re making some changes that impact Sage 50 Accounts and Sage 50cloud Accounts v26.2 and below.

Transport Layer Security (TLS) v1.0 and 1.1 is a security protocol that is widely used to facilitate privacy and data security for communications over the internet and is used in v26.2 and below.

In June 2018, the Internet Engineering Task Force (IETF) formally discourage the use of TLS 1.0 and 1.1 and highly recommends the use of TLS 1.2 and 1.3.


What this means for you

By 30 September 2022, we’re aiming to switch off TLS 1.0 and 1.1 for our remaining services, AutoUpdate and Sage License Server following the latest industry standards.

Once we switch off, anyone using Sage 50 Accounts or Sage 50cloud Accounts v26.2 or below will no longer be able to access their software.


Next steps?

You can check your current version and find your serial number within your software in Help and About.

If you are using v26.2 or below, please call us on 0161 413 5040 to discuss upgrading as soon as possible.


Need help?

We have a team of specialists on-hand should you need support with your update. Call us on 0161 413 5040, or email support@liquidaccounts.com


 

Sign up for a free trial today and see how our cloud accounting software can benefit your business.

Try free

Leave a Reply

Your email address will not be published.